站內搜尋:Yahoo搜尋如果沒有給完整的網址,請在站內再搜尋一次!

2011-11-01

在Xampp 1.7.7環境下,安裝Xoops 2.5.1a,無法順利完成所有的預設安裝步驟?

Xampp 1.7.7 的 php 是 5.3.8版,符合安裝 Xoops 2.5.x 的php版本需求(5.2以上),但安裝的過程陸續會出現類似以下的訊息,接著無法進行下一步驟,以致無法完成預設的安裝步驟...


Strict Standards: Non-static method XoopsLoad::load() should not be called statically in C:\xampp\htdocs\myg\include\common.php on line 49

Strict Standards: Non-static method XoopsLoad::loadCore() should not be called statically in C:\xampp\htdocs\myg\class\xoopsload.php on line 71

Strict Standards: Non-static method XoopsLoad::loadCoreConfig() should not be called statically in C:\xampp\htdocs\myg\class\xoopsload.php on line 91



解決這個問題的方法
問題出在php.ini的預設設定值,error_reporting 的預設值是 E_ALL | E_STRICT,把這個預設值調為:
error_reporting = E_ALL | ~E_STRICT
這樣就可以讓一大推錯誤訊息消失了!試試看吧!

不過這只是讓錯誤訊息消失而已,問題應該還是存在的!錯誤訊息是不見了,但接下來出現的是一個空白頁,一樣無法完成預設的安裝步驟...,問題出在哪裡呢?
(參考資料:http://www.zendchina.net/?action-viewnews-itemid-2296)

Xoops 2.5需要使用Zend Optimizer的功能...
Xampp 1.7以前的版本(不含1.7),預設安裝了Zend Optimizer,但沒有啟用Zend Optimizer,只要修改 php.ini 中的zend_optimizer.enable_loader的設定值,把 0改成1,重新啟動Apache,Zend Optimizer就啟用了。
但Xampp 1.7版以後,使用php 5.3的版本,Zend Optimizer 3.3.3 只支援 php 5.2.x (官網上有寫runtime for php 5.2 and earlier)...
所以目前看來,要在Xampp 1.7.x上run Xoops 2.5.x 應該會有困難!

沒有留言:

張貼留言